리자

libphp4.so: cannot restore segment prot after reloc: Permission denied 

· 2007-10-17 (수) 16:36:29 · 4368

[root@localhost libexec]# /usr/local/apache/bin/apachectl configtest
Syntax error on line 224 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: cannot restore segment prot after reloc: Permission denied

이런 황당한 에러는... 아래와 같이 하면 해결됨.

[root@localhost libexec]# restorecon -R -v /usr/local/apache/libexec

또는

[root@localhost libexec]# chcon -t texrel_shlib_t /usr/local/apache/modules/libphp4.so

[이 게시물은 관리자님에 의해 2011-10-31 17:32:05 Linux에서 이동 됨]
|
댓글을 작성하시려면 로그인이 필요합니다.

개발자팁

5,403건

개발과 관련된 유용한 정보를 공유하세요. 질문은 QA에서 해주시기 바랍니다.

+
분류 제목 글쓴이 날짜 조회
기타 07-05-16 조회 2,830
기타 07-05-16 조회 3,922
기타 07-05-15 조회 9,289
기타 07-05-13 조회 3,218
기타 07-05-10 조회 5,592
JavaScript 07-05-09 조회 3,320
Flash 07-05-09 조회 6,163
기타 07-05-09 조회 5,172
JavaScript 07-05-09 조회 6,247
기타 07-05-08 조회 3,140
기타 07-05-08 조회 4,630
기타 07-05-05 조회 4,397
기타 07-05-04 조회 2,866
JavaScript 07-05-04 조회 2,641
기타 07-05-04 조회 3,184
기타 07-05-04 조회 3,851
Flash 07-05-04 조회 3,231
Flash 07-05-04 조회 3,809
MySQL 07-05-04 조회 7,020
기타 07-05-04 조회 3,366
PHP 07-05-02 조회 4,778
JavaScript 07-04-30 조회 1.2만
기타 07-04-28 조회 3,046
Flash 07-04-28 조회 7,166
기타 07-04-27 조회 4,446
JavaScript 07-04-27 조회 4,514
기타 07-04-26 조회 4,227
JavaScript 07-04-26 조회 4,078
기타 07-04-26 조회 6,171
Flash 07-04-26 조회 5,389