OpenSSL for HTTP G4 에러 수정판 > 그누4 플러그인

그누4 플러그인

그누보드에는 여러가지 기능 추가가 쉽도록 제작 되었습니다.
플러그인의 저작권은 해당 플러그인 제작자님께 있으며, 그누보드의 저작권과 다를 수 있습니다.
플러그인 다운로드시 좋아요와 감사의 코멘트를 남기시면 제작자에게 큰 힘이됩니다. ^^y

OpenSSL for HTTP G4 에러 수정판 정보

OpenSSL for HTTP G4 에러 수정판

첨부파일

첨부파일 G4_Openssl_Http.zip (115.9K) 92회 다운로드 2015-04-01 13:27:03

본문

안녕하세요. 아파치입니다.

JS빌더에 letsgolee님의 OpenSSL for HTTP 프로그램을 연동 해 보려고 그누보드4용도 같이 만들었습니다.

letsgolee님께서 혼쾌히 허락을 해 주셔서 진행 할 수 있었습니다. 다시 한번 사용을 허락해 주셔서 감사 합니다.

# 사용 체크를 해제 해도 정상 작동 되도록 수정 한 버전입니다.

# 그누보드 4.37.25 에서 테스트 하였습니다.

사용법은 간단합니다.

다운받으신 파일의 압축을 풀고 자신의 계정에 업로드 하시고 관리자로 로그인후
환경설정 > OpenSSL 에서 OpenSSL 사용과 RSA PEM키 생성 체크박스에 클릭하시고 확인 버튼을 누르시면 됩니다.

압축 해제시 동봉된 readme.txt. 파일을 한번씩 읽어 주시기 바랍니다.
그리고 letsgolee님께서 조만간 다음버전 배포가 있을거라고 하셨습니다....^^


OpenSSL for HTTP의 안내는 letsgolee님께서 원본을 배포하신 게시물에 자세히 설명되어져 있습니다...^^
http://sir.co.kr/bbs/board.php?bo_table=g5_plugin&wr_id=14


# 확인하지 못한 에러가 있을 수 있습니다. 댓글로 알려 주시면 확인하도록 하겠습니다.



아래 내용은 해당 링크에서 발취해온 내용 입니다.

많은 분들이 OpenSSL for HTTP를 적용하고도 SSL보안서버 구축을 한 가운데서 사용을 해야 하는지에 대해 궁금해 하는 것같습니다. OpenSSL for HTTP를 설치하였다면 SSL 보안서버 구축을 하지 않아도 됩니다. 다음은 관련 규정입니다. 규정에서 "보안서버는 다음 각 호 중 하나의 기능을 갖추어야 한다"가 있습니다. OpenSSL for HTTP는 이 중 두 번째에 해당합니다.

개인정보의 기술적/관리적 보호조치 기준 
(방송통신위원회고시 제2009-21호)	

제2조(정의) 이 기준에서 사용하는 용어의 뜻은 다음과 같다. 
9. “보안서버”라 함은 정보통신망에서 송?수신하는 정보를 암호화하여 전송하는 웹 서버를 말한다. 

제6조(개인정보의 암호화) 
③ 정보통신서비스 제공자 등은 정보통신망을 통해 이용자의 개인정보 및 인증정보를 송/수신할 때에는 안전한 보안서버 구축 등의 조치를 통해 이를 암호화해야 한다. 보안서버는 다음 각 호 중 하나의 기능을 갖추어야 한다. 
1. 웹 서버에 SSL(Secure Socket Layer) 인증서를 설치하여 전송하는 정보를 암호화하여 송/수신하는 기능 
2. 웹 서버에 암호화 응용프로그램을 설치하여 전송하는 정보를 암호화하여 송/수신하는 기능 



스폰서링크

댓글 전체

좋은 자료 감사합니다. 덕분에 쉽게 SSL 적용을 할 수 있을거 같은데..문제는 기술된 방법데로 압축풀어 각 폴더에 파일 덮어씌운후 관리자로 로그인하여 openssl메뉴로 들어가면 페이지에 다음과 같은 메시지가 나옵니다.

alter table g4_config ADD `cf_http_openssl_use` tinyint(4) NOT NULL default '0', ADD `cf_pem_privatekey` varchar(900) NOT NULL default '', ADD `cf_pem_publickey` varchar(300) NOT NULL default ''

1074 : Too big column length for column 'cf_pem_privatekey' (max = 255). Use BLOB instead

error file : /adm/http_openssl_form.php

그래서 http_openssl_form.php에 cf_pem_privatekey와 cf_pem_publickey의 varchar를 255로 바꿔주었더니 페이지 내용이 제대로 나옵니다. 하지만 사용과 키생성에 체크하고 확인 버튼을 클릭하면 다음과 같은 에러 메시지가 나오네요..

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /kfidc/home/jungkawon/html/lib/http_openssl/rsa.class.php on line 251

왜 그런걸까요? 이 방면으론 무뇌라..ㅜㅜ
한가지 특이사항 올립니다.

"http_openssl.lib.php" 함수에서 $g4[''] 환경변수가 의미가 없습니다.

global 선언 해줘야 할듯합니다. 두개의 함수(http_openssl_simple_prepare, http_openssl_prepare)에 물론 도메인 접근시에 해당 에러는 발견되지 않습니다.

그리고 감사히 잘쓰겠습니다. ^^ 좋아요 up~~!!

ps) euc-kr 버젼도 있었으면 하는 바램하나 올립니다. ㅠ,.ㅠ
전체 3,524 |RSS
그누4 플러그인 내용 검색

회원로그인

진행중 포인트경매

  1. EditPlus5 (에디트플러스5 1인용)

    참여24 회 시작18.04.22 18:39 종료18.04.27 18:27
  2. 일전에 말씀드린 자전거용품 몇개 찾아봤습니다..

    참여16 회 시작18.04.22 14:55 종료18.04.27 14:55

(주)에스아이알소프트 (06253) 서울특별시 강남구 도곡로1길 14, 6층 624호 (역삼동, 삼일프라자) 대표메일:admin@sir.kr
사업자등록번호:217-81-36347 대표:홍석명 통신판매업신고번호:2014-서울강남-02098호 개인정보보호책임자:이총

© SIRSOFT