그누보드(영카트) 5.4.9 > 그누보드5 다운로드

그누보드5 다운로드

SIR은 그누보드를 만들 뿐 프로그램의 설치, 운영방법, 설정문제에 관한 도움을 드리지는 않습니다.

그누보드(영카트) 5.4.9 정보

그누보드(영카트) 5.4.9

첨부파일

gnuboard5-5.4.9.zip (11.8M) 364회 다운로드 2021-06-24 16:00:47
gnuboard5-5.4.9.tar.gz (10.2M) 81회 다운로드 2021-06-24 16:00:47
gnuboard5.4.9.patch.zip (36.2K) 108회 다운로드 2021-06-24 16:00:47

본문

# 변경된 사항

그누보드 버전 5.4.9 수정
https://github.com/gnuboard/gnuboard5/commit/cfc6804ee52a213f90f40e2a950ae2934cf0c54c

현재 false 값만 반환하는 get_magic_quotes_gpc() 관련 코드 제거, PHP7.4.0에서 DEPRECATED 되었습니다. (엑스엠엘님,210624)
https://github.com/gnuboard/gnuboard5/commit/e928df8a8c634576c490cfc79ef40a59be4fe4d7

$subject 가 첫번째 조건에 만족하면 $cont 를 초기화 하지 못하는 보안 취약점 수정 (munsiwoo님,210623)
https://github.com/gnuboard/gnuboard5/commit/911503e0556331c9fcf170c10b2c235bb01d85b1

갤러리 이미지수 설정을 select type 에서 input type 으로 수정 (사노라가노라님,210223)
https://github.com/gnuboard/gnuboard5/commit/cc2524e3a4e18bff92fcc57109e513514f1bd362

PHP 8.x 에서 data/dbconfig.php 의 define('G5_USE_SHOP', false); 와 같이 영카트 사용 안함 설정시 나오는 오류 수정 (몰라무서워님외,210623)
https://github.com/gnuboard/gnuboard5/commit/d4a63cd1058044af77dac11bd49a7c588dbfce54

PHP 8.x 버전에서 G5_USE_SHOP 이 false 인 경우 테마를 사용하는 경우에 상수 부분에서 발생하는 오류 수정 (dinist님,210618)
https://github.com/gnuboard/gnuboard5/commit/01c5771c1633c1c139f961230f1b6341856d3cab

댓글 17개

그누보드 신규 설치 시 기본 게시판 그룹이 쇼핑몰로 생성 됨.

config.php 에 G5_YOUNGCART_VER 기본으로 정의 되어 있어서 발생하는 증상.

install_db.php 244번째 줄
$tmp_gr_id = defined('G5_YOUNGCART_VER') ? 'shop' : 'community';
$tmp_gr_subject = defined('G5_YOUNGCART_VER') ? '쇼핑몰' : '커뮤니티';
adm / theme_preview.php  33줄
'$bo_table'  -->  '{$bo_table}'

adm / theme_preview.php  175줄
'$wr_id'  -->  '{$wr_id}'

bbs / ajax.filter.php  29줄
die("{\"subject\":\"$subj\",\"content\":\"$cont\"}");
를 아래로 변경
die("{\"subject\":\"{$subj}\",\"content\":\"{$cont}\"}");
그누보드 5.4.6~>9까지 통합패치가 배포되고 있는데,
영카트와의 통합을 위한 패치인지...

아니면 순수 그누보드 5.4.5 취약점을 보완하는 부분이 포함된 패치인지...
궁금합니다.

"변경된 사항"에 자세히 언급되었으리라 생각됩니다만,
읽어도 잘 알지도 못하고 해서, 그누 패치만 덮어 씌워가며 사용해 왔기에,
영카트가 포함된 패치는 엄두가 안 납니다.
크게 문제될게 없다면 5.4.5로 버텨 보려고요.
무료 배포본을 쓰다보면 어쩔 수없이 겪게되는 애로사항이기도 해서...
안녕하세요.
관리의 어려움으로 그누보드와 영카트를 합쳐 배포하게 되었습니다.
기존 그누보드 사용자님들께서는 그누보드 관련 파일만 패치하시면 됩니다.
감사합니다.
그누 관련파일만 패치하는 방법이 있다 하시니, 패치방법을 공부해 보겠습니다.

저처럼 그누만 사용하는 초보 분들이 많으실 것 같아서,
그분들을 대신해서 욕먹을 각오로 질문드렸습니다. 양해바랍니다.

그누만 사용하시는 전문가 분께서 "그누 관련 패치 매뉴얼"을 올려주시기를 기다려 봅니다.
전체 275 |RSS

회원로그인

(주)에스아이알소프트 / 대표:홍석명 / (06211) 서울특별시 강남구 역삼동 707-34 한신인터밸리24 서관 1404호 / E-Mail: admin@sir.kr
사업자등록번호: 217-81-36347 / 통신판매업신고번호:2014-서울강남-02098호 / 개인정보보호책임자:김민섭(minsup@sir.kr)
© SIR SOFT