AWS Lightsail 에서 PHP8 빠르게 설치하기 > 개발자팁

개발자팁

개발과 관련된 유용한 정보를 공유하세요.
질문은 QA에서 해주시기 바랍니다.

AWS Lightsail 에서 PHP8 빠르게 설치하기 정보

웹서버 AWS Lightsail 에서 PHP8 빠르게 설치하기

본문

추천
4

댓글 9개

영상과 똑같은 방법으로 따라해봤는데 PHP-FPM에서 막히네요.

$ systemctl start php-fpm nginx mariadb
Job for php-fpm.service failed because the control process exited with error code. See "systemctl status php-fpm.service" and "journalctl -xe" for details.


$ systemctl status php-fpm.service
  php-fpm.service - The PHP FastCGI Process Manager
  Loaded: loaded (/usr/lib/systemd/system/php-fpm.service; enabled; vendor preset: disabled)
  Active: failed (Result: exit-code) since Tue 2021-08-10 06:47:49 UTC; 57s ago
  Process: 9889 ExecStart=/usr/sbin/php-fpm --nodaemonize (code=exited, status=78)
 Main PID: 9889 (code=exited, status=78)

Aug 10 06:47:49 ip-172-26-3-233.ap-northeast-2.compute.internal systemd[1]: Starting The PHP FastCGI Process Manager...
Aug 10 06:47:49 ip-172-26-3-233.ap-northeast-2.compute.internal php-fpm[9889]: [10-Aug-2021 06:47:49] ERROR: [pool www] cannot get uid for us...inx'
Aug 10 06:47:49 ip-172-26-3-233.ap-northeast-2.compute.internal php-fpm[9889]: [10-Aug-2021 06:47:49] ERROR: FPM initialization failed
Aug 10 06:47:49 ip-172-26-3-233.ap-northeast-2.compute.internal systemd[1]: php-fpm.service: main process exited, code=exited, status=78/n/a
Aug 10 06:47:49 ip-172-26-3-233.ap-northeast-2.compute.internal systemd[1]: Failed to start The PHP FastCGI Process Manager.
Aug 10 06:47:49 ip-172-26-3-233.ap-northeast-2.compute.internal systemd[1]: Unit php-fpm.service entered failed state.
Aug 10 06:47:49 ip-172-26-3-233.ap-northeast-2.compute.internal systemd[1]: php-fpm.service failed.
Hint: Some lines were ellipsized, use -l to show in full.
파일 전체 내용이 댓글로 등록이 어려워 구글문서 링크 공유합니다.
인스턴스를 지우고 새로 생성하여 동일하게 하여도 똑같은 오류가 뜨네요.

https://docs.google.com/document/d/1jnwmXHszfTnKf8nbI342POt0__Uq3SFIrsBzw0ev0cY/edit?usp=sharing
Aug 10 06:47:49 ip-172-26-3-233.ap-northeast-2.compute.internal php-fpm[9889]: [10-Aug-2021 06:47:49] ERROR: [pool www] cannot get uid for us...inx'

에러 내용이 잘려서 어떤 내용인지 알기 어렵네요.
이상하게 ~ sudo yum update 이게 안먹힐까요?
lightsail Amazon Linux 2 신청하고서
쉘접속하면 보통 sudo yum update하라고 메세지뜨는데
이 서버는 그게 없고, 막상 입력해도 먹히지 않고,

      __|  __|_  )
      _|  (    /  Amazon Linux 2 AMI
      ___|\___|___|

https://aws.amazon.com/amazon-linux-2/
[ec2-user@ip-17*-**-*-*** ~]$ sudo yum update
Loaded plugins: extras_suggestions, langpacks, priorities, update-motd
amzn2-core  | 3.7 kB  00:00:00   
No packages marked for update
@리자 감사합니다.

https://docs.aws.amazon.com/ko_kr/AWSEC2/latest/UserGuide/amazon-linux-ami-basics.html#package-repository

패키지 설치 방법으로 해보니 되더라구요
활성화를 안해서 그런듯합니다.
전체 5,131
개발자팁 내용 검색

회원로그인

(주)에스아이알소프트 / 대표:홍석명 / (06211) 서울특별시 강남구 역삼동 707-34 한신인터밸리24 서관 1404호 / E-Mail: admin@sir.kr
사업자등록번호: 217-81-36347 / 통신판매업신고번호:2014-서울강남-02098호 / 개인정보보호책임자:김민섭(minsup@sir.kr)
© SIR SOFT