크롬80버전 결제 이슈, 영카트5 주요패치 확인!

cafe24 centos 6.8 질문

컨텐츠몰 10% 할인 기간연장!
그누보드5
영카트5
매뉴얼
Q & A
제작의뢰
컨텐츠몰
부가서비스
소모임
커뮤니티
cafe24 centos 6.8 질문

QA

SIR 컨텐츠몰 10% 특별할인 - 코로나19 바이러스로 어려운 시기, SIR이 함께 하겠습니다.

cafe24 centos 6.8 질문

본문

서버를 Ubuntu로 만 사용하다가

 

centos6.8 이 설치된 cafe24 서버호스팅을 작업하는중입니다만

 

MariaDB-server를 설치하려고하면

 

**********************

# yum install MariaDB-server
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.kakao.com
 * epel: mirror.premi.st
 * extras: mirror.kakao.com
 * ius: mirrors.kernel.org
 * rpmforge: apt.sw.be
 * updates: mirror.kakao.com
Resolving Dependencies
--> Running transaction check
---> Package MariaDB-server.x86_64 0:10.3.14-1.el6 will be installed
--> Processing Dependency: perl(DBI) for package: MariaDB-server-10.3.14-1.el6.x86_64
--> Processing Dependency: galera for package: MariaDB-server-10.3.14-1.el6.x86_64
--> Processing Dependency: MariaDB-common for package: MariaDB-server-10.3.14-1.el6.x86_64
--> Processing Dependency: MariaDB-client for package: MariaDB-server-10.3.14-1.el6.x86_64
--> Running transaction check
---> Package MariaDB-client.x86_64 0:10.3.14-1.el6 will be installed
---> Package MariaDB-common.x86_64 0:10.3.14-1.el6 will be installed
--> Processing Dependency: MariaDB-compat for package: MariaDB-common-10.3.14-1.el6.x86_64
---> Package galera.x86_64 0:25.3.26-1.rhel7.el7.centos will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: galera-25.3.26-1.rhel7.el7.centos.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: galera-25.3.26-1.rhel7.el7.centos.x86_64
--> Processing Dependency: libboost_program_options.so.1.53.0()(64bit) for package: galera-25.3.26-1.rhel7.el7.centos.x86_64
---> Package perl-DBI.x86_64 0:1.609-4.el6 will be installed
--> Running transaction check
---> Package MariaDB-compat.x86_64 0:10.3.14-1.el6 will be installed
---> Package galera.x86_64 0:25.3.26-1.rhel7.el7.centos will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: galera-25.3.26-1.rhel7.el7.centos.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: galera-25.3.26-1.rhel7.el7.centos.x86_64
--> Processing Dependency: libboost_program_options.so.1.53.0()(64bit) for package: galera-25.3.26-1.rhel7.el7.centos.x86_64
--> Finished Dependency Resolution
Error: Package: galera-25.3.26-1.rhel7.el7.centos.x86_64 (mariadb)
           Requires: libboost_program_options.so.1.53.0()(64bit)
Error: Package: galera-25.3.26-1.rhel7.el7.centos.x86_64 (mariadb)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Error: Package: galera-25.3.26-1.rhel7.el7.centos.x86_64 (mariadb)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
 You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
kernel-firmware-2.6.32-754.3.5.el6.noarch is a duplicate with kernel-firmware-2.6.32-696.13.2.el6.noarch
kernel-headers-2.6.32-754.3.5.el6.x86_64 is a duplicate with kernel-headers-2.6.32-696.13.2.el6.x86_64
 

 

*********************************************************

 

위와 같이 나옵니다.

 

이걸 아무리 찾아서 해결하려고 해도 

뭘 손대야 할지 잘 모르겠네요

 

어떻게 하는게 좋을까요?

 

이 글을 내 페이스북 계정으로 보내기 이 글을 내 트위터 계정으로 보내기

이 질문에 댓글 쓰기 :

답변 5

채택됨

BlueAngel님의 답변

의존성 문제같긴한데요...

repo 에 버전이 어떻게 지정되어있나요? 

 

vi /etc/yum.repos.d/MariaDB.repo

https://yum.mariadb.org/

 

 

http://blog.naver.com/PostView.nhn?blogId=andwise&logNo=221006760342&beginTime=0&jumpingVid=&from=search&redirect=Log&widgetTypeCall=true

 

 

 

 

주소복사
채택됨
답변의 댓글
플래토님의 댓글
알려주신 내용으로
위의 오류는 해결했습니다.

제가 이것저것 긁어서 넣다가
버전을 Centos7을 넣었더라구요

다른 현상이 있는데 그건 이질문과 다른 사항이니 또 찾아봐야겠네요

감사합니다.

다케미카코님의 답변

혹시 가상 서버 호스팅 쓰시는 거라면 불가능할거 같은데요.

있는 그대로 사용을 해야 되서 관리자 패널쪽에 세팅 변경이 있으니 그걸로 변경 처리 하시면 될거 같고,

기존에 디비 웹은 백업 따로 하시고 다시 넣는 작업을 해야 할듯...

주소복사
답변의 댓글

亞波治님의 답변

원래 yum update 를 진행하면 6.8버전에서 7.x 버전으로 자동 업데이트 되는게 맞습니다.

 

위의 현상은 해결 하셨다니 제가 배포하는 AAI로 설치를 해 보시길......

주소복사
답변의 댓글

플래토님의 답변

몇가지 하려던 작업을 말씀드리면

 

centos 에서 apache + php 7 + mariadb를 설치하려다가

뭔가 커널때문에 안맞는거 같아서

centos7로 업그레이드하는게 

yum으로 안되더라구요

카페24에서 일주러 그렇게 셋팅을 해둔것인지도 모르겠지만요

 

그리고 계속 눈에 걸리는게 아래

 

rhel7.el7.centos.x86_64

이게 오류난 모듈에 있는걸로 봐서 

 

이부분이 centos 6.8과 안맞는거 같은데요

그 이상은 잘 모르겠습니다

 

의존성을 맞추는방법도 

설치를 잘 하는 방법도 ㅠㅠ

 

 

주소복사
답변의 댓글
亞波治님의 댓글
6.8과 7.x의 의존성이 맞지 않아서 설치 진행이 되지 않습니다.
해당 모듈 이 있는지 확인 후 삭제 하시거나
yum install --skip-broken MariaDB-server 으로 설치를 진행 하시면 됩니다.

BlueAngel님의 답변

https://blog.cafe24.com/2001?category=411035

 

yum clean all 캐쉬 삭제해보셨나요?

주소복사
답변의 댓글
플래토님의 댓글
제가 설치하려는게 MariaDb라서 뭔가 다른걸까요?
주로 mysql만 사용하다가 maria로 셋팅하려고 한거였는데 잘 안되고
하루종일 씨름하니 정신이 멍.. 해지네요 ㅠㅠ
답변을 작성하시기 전에 로그인 해주세요.
전체 46
고마운 분의 도움으로 질문을 해결하셨다면, 채택을 눌러서 감사의 마음을 전하세요.
어떻게 질문해야 할지 모른다면 질문하는 방법을 읽어 보신후 질문해 보세요.
QA 내용 검색

회원로그인

(주)에스아이알소프트 (06253) 서울특별시 강남구 도곡로1길 14, 6층 624호 (역삼동, 삼일프라자) 대표메일:admin@sir.kr
사업자등록번호:217-81-36347 대표:홍석명 통신판매업신고번호:2014-서울강남-02098호 개인정보보호책임자:이총

© SIRSOFT