게시판생성, 글작성시 오류가 납니다.

버그신고
게시판생성, 글작성시 오류가 납니다.

QA

게시판생성, 글작성시 오류가 납니다.

본문

게시판생성시에도 오류가나고, 글작성시 아래처럼 오류가 납니다.

 

insert into g5_write_poto set wr_num = '-185', wr_reply = '', wr_comment = 0, ca_name = '', wr_option = 'html1,,', wr_subject = 'gagag', wr_content = '

asgdgdg

', wr_link1 = '', wr_link2 = '', wr_link1_hit = 0, wr_link2_hit = 0, wr_hit = 0, wr_good = 0, wr_nogood = 0, mb_id = 'osio', wr_password = '*4B97687211987C81D95F5C3C19C43', wr_name = 'admin', wr_email = '*** 개인정보보호를 위한 이메일주소 노출방지 ***', wr_homepage = '', wr_datetime = '2015-07-22 23:24:54', wr_last = '2015-07-22 23:24:54', wr_ip = '116.41.117.23', wr_1 = '', wr_2 = '', wr_3 = '', wr_4 = '', wr_5 = '', wr_6 = '', wr_7 = '', wr_8 = '', wr_9 = '', wr_10 = ''

1364 : Field 'wr_comment_reply' doesn't have a default value

error file : /bbs/write_update.php 

 

접속자도 별로 없는데 사이트가 디비오류가나서 매일 잠깐만 열려있다가 다운이 되길래 

그누보드 예전버젼에다가 5.0.35버젼을 덮었다가 다시 예전버젼을 덮었는데요.

 

디비오류는 해결이됬는데, 게시판생성과 글작성이 안되고 있는데요. 

최신버전으로 업데이트를 할경우에도 비슷한 오류가났었는데. 어딘가 파일이 제대로 바뀌지않았거나 안바뀌껴서 이런거같은데, 여기져기 바꿔봤는데 잘 모르겠네요.

아예 되돌리면 또 디비오류가 나는거 같고... 이런경우 어느 폴더 파일이 잘못된 건가요? 

js? lib?..

 

이 질문에 댓글 쓰기 :

답변 2

mysql 설정 변경으로 해결 가능합니다.

my.ini   파일 에서.. 

sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION" 

이 부분을 주석처리하고 mysql 재시작해보세요.

 

답변을 작성하시기 전에 로그인 해주세요.
전체 103,470 | RSS
QA 내용 검색

회원로그인

(주)에스아이알소프트 / 대표:홍석명 / (06211) 서울특별시 강남구 역삼동 707-34 한신인터밸리24 서관 1404호 / E-Mail: admin@sir.kr
사업자등록번호: 217-81-36347 / 통신판매업신고번호:2014-서울강남-02098호 / 개인정보보호책임자:김민섭(minsup@sir.kr)
© SIR SOFT