채택완료

리눅스에그누보드설치 질문드립니다.

Connect Error: Access denied for user 'sky7500'@'localhost' (using password: YES) 

/var/www/html 여기경로에넣는건맞구요..

저에러가뜨는데 왜뜨는건지..

그리고 db localholst.sql 이거는 어떤폴더에넣고 디비복원은 어떻게하는지 궁금합니다..


|

답변 3개 / 댓글 1개

채택된 답변
+20 포인트

기존 운영하시던 그누보드를 이전하신거 같은데, 이미 설치되어 있는(/data/dbconfig.php 가 생성되어 있음) 그누보드라서 mysql아이디(sky7500)으로 접근하려 하는데 이전하시려는 리눅스 서버에서는 해당 db사용자가 생성되어 있지 않거나 비밀번호가 틀려서 오류가 발생하고 있습니다.

1. /data/dbconfig.php 파일의 아이디/비밀번호가 기재되어 있는 부분을 수정

2. 동일한 아이디로 mysql 계정을 생성

3. /data/dbconfig.php 파일을 삭제하고 새로 설치

하는 방법이 있겠네요 

혹시 db쪽 비밀번호 확인해보셨나요? 비번 변경해보시고 새로 적용해 보시면

해결이 될듯하네요..

권한 문제 입니다.

sky7500는 ID는 접근 허용을 안하고 있습니다.

sql 파일 import는 어느 위치 에 넣어두어도 상관없습니다. 다만 shell에서 mysql bin path가

걸려 있으면 됩니다.

디비복원은

mysql -u[아이디] -p[비번] < localholst.sql

이런식으로 하시면됩니다. 

답변에 대한 댓글 1개

권한은 그럼 어떻게 해줘야될까요?

답변을 작성하려면 로그인이 필요합니다.