채택완료

Lets encrypt 무료 SSL 등록 질문있습니다.

CentOS 6.8 Nginx + php7 + MariaDB 환경의 개인 서버를 운영하고 있습니다.

lets encrypt 최종 단계...

letsencrypt-auto certonly 를 입력하고 이메일, 도메인 등 설정을 다 하고나면 마지막에 에러가 납니다. 

Copy
Failed authorization procedure. www.도메인.kr (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Failed to connect to 아이피:443 for tls-sni-01 challenge, 도메인.kr (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Failed to connect to 아이피:443 for tls-sni-01 challenge

80, 443 포트 모두 오픈 된 상태입니다.

하단 오류 내용도 그렇고 인터넷에서 봤는데요.

집 컴퓨터에서는 SSL 발급이 안됩니다.

→ Public IP와 Domain을 가지고 있어야 발급이 가능합니다. Router IP와 localhost로는 실행할 수 없습니다.

라는 내용입니다.. 집에서 개인이 운영하는 서버는 안된다는 말인가요,,?

그럼 무료 SSL도 등록 못하는 건가요..?

못한다면 가능한 무료 SSL 추천좀 부탁드립니다.ㅠㅠ

|

답변 1개 / 댓글 1개

채택된 답변
+20 포인트

집에서 개인이 운영하는 서버가 안되는건 아닙니다.

공인 아이피를 갖고 계시고 외부에서 접근이 가능한 상태여야만 인증서를 발급 받으실 수 있습니다.

http://www.yougetsignal.com/tools/open-ports/ 

올려드린 사이트에서 본인의 서버 80 포트가 정상적으로 오픈이 되어 있는지를 체크해보세요.

그리고 lets encrypt 의 경우 nginx conf파일에서 예외처리를 아래와 같이 해주셔야 합니다.

Copy
location ^~ /.well-known/acme-challenge/ {    allow all;}

마지막으로 지금 사용하시는 도메인이 도메인 등록기관에 등록된 정상적인 도메인인지도 확인 해보시구요.

https://whois.kisa.or.kr/kor/main.jsp 

답변에 대한 댓글 1개

답변 감사합니다. 우선 데스크탑 VM상에서 해보고 서버에 적용 해보려고 합니다.

답변을 작성하려면 로그인이 필요합니다.