보안서버 SSL 적용 후, htaccess 리다이렉트 설정 후 로그인 문제
안녕하세요.
htaccess이 잘못되었는지 함 봐주세요.
htaccess 리다이렉트 설정하면 로그인 오류가 발생합니다.
아래와 같이 htaccess 설정을 하면 로그인오류가 발생합니다.
"회원아이디나 비밀번호가 공백이면 안됩니다."
login_check.php 에서 윗부분을 주석처리하면 다음 번 alert가 차례대로 오류가 발생합니다.
htaccess를 제거하면 정상적으로 로그인이 됩니다.
config.php설정
define('G5_DOMAIN', 'https://aaaaa.com');
define('G5_HTTPS_DOMAIN', 'https://aaaaa.com:42447');
.htaccess 설정
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{HTTP_HOST} !^aaaaa\.com$ [NC]
RewriteRule ^ https://aaaaa.com%{REQUEST_URI} [R=301,L]
</IfModule>
답변 1개 / 댓글 3개
define('G5_HTTPS_DOMAIN', 'https://aaaaa.com:42447');
를 다음과 같이 포트 빼보세요.
define('G5_HTTPS_DOMAIN', 'https://aaaaa.com');
답변에 대한 댓글 3개
※ 포트넣고 폼전송 : alert($_POST['name']) 안보임, 포트빼고 폼전송 : alert($_POST['name']) 보임
답변을 작성하려면 로그인이 필요합니다.
포트번호를 빼면 SSL이 적용이 안되는 것 같습니다. 당연히 로그인은 됩니다.