mysql 질문이요..

2017-08-29 (화) 17:04:53 8,673

현재 mysql start를 하려고 하니

2017-08-29 16:53:04 632 [Note] Plugin 'FEDERATED' is disabled.

C:\mysql\bin\mysqld: Table 'mysql.plugin' doesn't exist

2017-08-29 16:53:04 632 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.

2017-08-29 16:53:04 632 [Note] InnoDB: Using atomics to ref count buffer pool pages

2017-08-29 16:53:04 632 [Note] InnoDB: The InnoDB memory heap is disabled

2017-08-29 16:53:04 632 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions

2017-08-29 16:53:04 632 [Note] InnoDB: Memory barrier is not used

2017-08-29 16:53:04 632 [Note] InnoDB: Compressed tables use zlib 1.2.3

2017-08-29 16:53:04 632 [Note] InnoDB: Not using CPU crc32 instructions

2017-08-29 16:53:04 632 [Note] InnoDB: Initializing buffer pool, size = 128.0M

2017-08-29 16:53:04 632 [Note] InnoDB: Completed initialization of buffer pool

2017-08-29 16:53:04 632 [Note] InnoDB: Highest supported file format is Barracuda.

2017-08-29 16:53:04 632 [Note] InnoDB: The log sequence numbers 1600747 and 1600747 in ibdata files do not match the log sequence number 1600757 in the ib_logfiles!

2017-08-29 16:53:04 632 [Note] InnoDB: Database was not shutdown normally!

2017-08-29 16:53:04 632 [Note] InnoDB: Starting crash recovery.

2017-08-29 16:53:04 632 [Note] InnoDB: Reading tablespace information from the .ibd files...

2017-08-29 16:53:04 632 [Note] InnoDB: Restoring possible half-written data pages 

2017-08-29 16:53:04 632 [Note] InnoDB: from the doublewrite buffer...

2017-08-29 16:53:05 632 [Note] InnoDB: 128 rollback segment(s) are active.

2017-08-29 16:53:05 632 [Note] InnoDB: Waiting for purge to start

2017-08-29 16:53:05 632 [Note] InnoDB: 5.6.37 started; log sequence number 1600757

2017-08-29 16:53:05 632 [Note] Server hostname (bind-address): '*'; port: 3306

2017-08-29 16:53:07 632 [Note] IPv6 is not available.

2017-08-29 16:53:07 632 [Note]   - '0.0.0.0' resolves to '0.0.0.0';

2017-08-29 16:53:07 632 [Note] Server socket created on IP: '0.0.0.0'.

2017-08-29 16:53:07 632 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.user' doesn't exist

계속 에러가 뜨는데 원인을 도저히 모르겠네요ㅜ 부탁드립니다. 

|

답변 5개 / 댓글 3개

호스팅사에 문의 안대나여

호스팅사 문의가 제일 빠른데말이죠

윈도우 서버면 업그레이드시 문제가 발생한거 같은데요

문제되면 데이타 백업하고 다시 설치해야 되는 사태가 생길수도 ㅠ.ㅜ

mysql 설치가 잘안된거같네요

http://k-flow.tistory.com/75

참고해보셔요

답변에 대한 댓글 1개

윈도우서버라.. 리눅스서버랑 좀 다르네요 ㅜ

mysql_upgrade -u <user> -p

이거 하시면 될겁니다.

답변에 대한 댓글 1개

나시님이 알려주신데로 해쓴ㄴ데.. Failed while fetching server version! could be due to unauthorized access 라고 뜨네요..

C:\mysql\bin\mysqld: Table 'mysql.plugin' doesn't exist //플러그인 테이블이 존재하지 않으니 

2017-08-29 16:53:04 632 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.//업데이트 하라곱쇼 ?

mysql 이 제대로 설치 되지않은거 아닐까요? ?

답변에 대한 댓글 1개

되던 mysql 서버가 갑자기..오늘 안되네요.. 잘운영중이였는데 어느순간에.. 후..

답변을 작성하려면 로그인이 필요합니다.