채택완료

자동등록방지 이미지 오류

2017-11-23 (목) 17:07:27 3,548

캡챠 이미지가 컴퓨터마다 보이고 안보이고 하네요 ㅠㅠ

제 자리에서는 보이는데 다른 몇몇 직원들은 보이지 않습니다.

data 폴더 권한설정도 해보고 세션, 캐시, 캡챠 파일 삭제 해봐도 소용 없네요.

전부 크롬에서 확인했구요, 에러가 나는 케이스에서는

Failed to load http://domain.com/plugin/kcaptcha/kcaptcha_session.php: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'http://www.domain.com' is therefore not allowed access.

jquery-1.8.3.min.js:2 Failed to load http://domain.com/plugin/kcaptcha/kcaptcha_mp3.php: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'http://www.domain.com' is therefore not allowed access.

상기 에러메세지가 콘솔에 찍힙니다.

서칭해보니 크로스도메인 이슈라고 하는데 정확한 해결방법을 잘 모르겠네요 ㅠㅠ

조언 부탁드립니다!

답변 1개 / 댓글 2개

채택된 답변
+20 포인트

http://domain.com/서버에서 외부의 접근을 막아놓은거같은데....

인증된 ip로만 접속가능하게요...(로그인같은)

서버에서 외부접근허용하게 요청 하시거나

호스팅업체에 문의해보시는게 빠른 방법인듯 합니다.

답변에 대한 댓글 2개

답변 감사합니다!
호스팅업체에도 한번 문의해봐야겠네요 :)
감사합니다!
@ChocoMam 참고로 http://domain.com/ 이건
외부접근방지를위한 php내부 도메인변경코드로 변경된 주소일수도 있습니다.
그래서 호스팅업체에 문의해보라고한겁니다.

답변을 작성하려면 로그인이 필요합니다.