nginx 설정 문의 드립니다.
nginx v1.16.1 사용중에 RESTFUL API 구성하려 세팅하는 과정중에
trace method -> put, delete 오류메세지가 나오는 현상이 발생되었습니다.
get, post는 기본 세팅값에 적용되어 허용이 되나
put, delete method의 경우 405 오류가 발생하네욤.
혹시 설정중에 따로 변경해야할 부분이 있는지 문의드립니다.
|
답변 1개
다케미카코
2019-12-27 (금) 09:28:09
방법이 두개 인데 한개는 .htaccess 에다가
Copy
RewriteEngine on
RewriteCond %{REQUEST_URI} ^/users/create/?.*$
RewriteCond %{REQUEST_METHOD} =GET
RewriteRule ^(.*)$ http://airbrake.io/users/new$1 [R=405,L]
아니면 다른 방법으로 /usr/local/nginx/conf 안에 nginx.conf 파일을
Copy
server {
listen 80;
listen 443 ssl;
server_name airbrake.io;
location /users/create {
if ($request_method = POST) {
return 405 https://airbrake.io/users/create$request_uri;
}
}
}
답변을 작성하려면 로그인이 필요합니다.