1.
PhpMyAdmin 에서 wr_11 ~ wr_15 까지
5개의 필드를 추가했습니다.
2.
write_update.skin.php 에
<?php
$sql = " update $write_table
set wr_11 = '$wr_11',
wr_12 = '$wr_12',
wr_13 = '$wr_13',
wr_14 = '$wr_14',
wr_15 = '$wr_15'
where wr_id = '$wr_id' " ;
sql_query($sql);
?>
를 추가하고
글쓰기하면 HTTP 500에러가 나오네요.....
무엇을 잘못한걸까요?
답변 4개 / 댓글 5개
이상하네요 위 코드에서는 에러 날 것이 없는데
bbs/write_update.php 에서
@include_once($board_skin_path.'/write_update.skin.php'); 변경-->
include_once($board_skin_path.'/write_update.skin.php');
위 소스에서 sql_query($sql , true); exit;
이렇게 해서 에러가 나오는지 보세요
답변에 대한 댓글 1개
답변에 대한 댓글 2개
하루종일 고민하다가 겨우 해결했네요..
알려주신 팁은 저장해뒀다가 찾아써야겠네요...
모르면 고생이라...ㅠㅠ
ini_set('display_errors', '1');
코드를 상단에 추가하여 500 에러의 구체적인 내용을 확인하는 것이 좋을 듯 합니다.
그리고 필요한 경우 sql 문을 출력하여, 해당 sql문을 DB 에 직접 실행해서 정상적으로 실행되는지도 체크해보는 것이 좋습니다.
echo $sql;
exit;
답변에 대한 댓글 1개
/bbs/write.php 파일 수정. ($i<=20;) 20으로 수정
// 가변 변수로 $wr_1 .. $wr_10 까지 만든다.
for ($i=1; $i<=20; $i++) {
[편리님의 조언]
MySQLi 지원 버전으로 패치를 한 경우 mysql_query 함수 등을 사용하면 mysqli 와 혼용으로
오류가 발생합니다. config.php 파일의 G5_MYSQLI_USE 설정을 false 로 변경해 보시기 바랍니다.
답변에 대한 댓글 1개
게시판 전체에 필드추가가 아니고, 특정 게시판에만 필드 추가를 한거라서요...
config.php 파일의 G5_MYSQLI_USE 설정을 false 로 변경해보니까
아예 website가 죽어버리네요..ㅠㅠ
답변을 작성하려면 로그인이 필요합니다.
write_update.skin.php 에서 여분필드 추가하는 부분을
맨 위로 올리니까 잘 되네요...
감사합니다.^^