채택완료

백업이 나는 에러 이게 왜이러죠?

2021-05-26 (수) 21:09:04 2,476

g5_auth.MYD' not found (Errcode: 2) when using LOCK TABLES

mysqldump시 위같은 에러가 나는데 아시는분 계실까요?

|

답변 3개 / 댓글 2개

채택된 답변
+20 포인트

원인 : 해당 table에 lock이 걸려 있어 덤프가 안되는 문제 입니다.

조치 : mysqldump에 --lock-all-table 옵션을 추가 하여 진행 하면 정상적으로 백업 됩니다.

Ex) mysqldump -u [User] -p --lock-all-tables [DBName] > [dump file name].sql

답변에 대한 댓글 1개

mysqldump: Couldn't execute 'show create table `g5_auth`': File './jayking/g5_auth.MYD' not found (Errcode: 2) (29)

옵션추가해서 하니 에러나요..ㅜㅜ;
2021-05-27 (목) 06:32:32

mysql> drop table g5_auth;

CREATE TABLE `g5_auth` (
  `mb_id` varchar(20) NOT NULL DEFAULT '',
  `au_menu` varchar(20) NOT NULL DEFAULT '',
  `au_auth` set('r','w','d') NOT NULL DEFAULT '',
  PRIMARY KEY (`mb_id`,`au_menu`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 ;

이렇게 해서 테이블을 복구해 보세요.

2021-05-26 (수) 22:08:03

REPAIR TABLE g5_auth;

한번 해 보세요.

https://dev.mysql.com/doc/refman/5.7/en/rebuilding-tables.html

답변에 대한 댓글 1개

mysql> REPAIR TABLE g5_auth;
+-----------------+--------+----------+-----------------------------------------------------+
| Table | Op | Msg_type | Msg_text |
+-----------------+--------+----------+-----------------------------------------------------+
| jayking.g5_auth | repair | Error | File './jayking/g5_auth.MYD' not found (Errcode: 2) |
| jayking.g5_auth | repair | Error | Can't find file: 'g5_auth' (errno: 2) |
| jayking.g5_auth | repair | error | Corrupt |
+-----------------+--------+----------+-----------------------------------------------------+

이것도 이렇게 에러가 나네요..

답변을 작성하려면 로그인이 필요합니다.