그누보드 프로젝트 새로 생성중인데, 권한을 부여해도 안되는데 무엇을 조치해야할까요?

2024-08-12 (월) 11:39:15 1,915

nginx와 연동해서 사용하려 하고있고, php는 8.1버전을 사용중입니다.

그누보드5 다운로드에 들어가서 정식버전 5.6.4을 다운로드하고, 압축해제한 후 서버에 업로드했습니다.

nginx의 설정도 완료했고, 도메인을 입력해서 접근하면

  • data/dbconfig.php

이 파일을 찾을수 없다는 페이지가 뜨고, data를 생성 후 권한 707을 부여하라고 나왔습니다.

이에 config.php가 존재하는 위치에 data 폴더를 생성 후, chmod -R 707 data 명령어를 실행하여 권한을 부여했습니다.

그런데 계속 권한을 부여하라는 오류가 발생합니다.

3730852984_1723430268.2797.png

폴더 생성

3730852984_1723430212.4164.png

data 폴더 권한 설정

3730852984_1723430284.1095.png

권한설정 이후 홈페이지 에러

이렇게 나오고있는데, 권한설정 이후 따로 처리해야만 할 것이 있을까요?

|

답변 1개 / 댓글 1개

"하위 디렉터리 이동 " 이 부분 체크 해주시고

확인을 눌러주세요.

폴더 권한만 707이 아니라 폴더 하위 및 파일도 권한이 707을 준다는 의미 입니다.

답변에 대한 댓글 1개

답변주셔서 감사합니다.
말씀해주신 것처럼 해보아도 동일한 오류로 진행이 안되고 있는 상황입니다.

답변을 작성하려면 로그인이 필요합니다.