청

설치할때 config삽입쿼리값중에 필드 몇개가 누락된거 같은데요?

· 2013-06-21 (금) 16:24:56 · 1317 · 7
OS : windows7 64bit
그누보드4s : g4s-4.0b32

설치할때 3단계 중

전체 테이블 생성 완료
Field 'cf_add_script' doesn't have a default value

이런 메세지가 뜨고 진행이 안되는데요
install_db.php 파일에 인서트 구분에 필드가 누락된거 같아요
그냥 대강

cf_add_script = '',
cf_facebook_appid = '',
cf_facebook_secret = '',
cf_twitter_key = '',
cf_me2day_key = '',
cf_twitter_secret = '',

공백으로 필드 추가해서 인스톨 시켰는데
원래 이런건지 테이블 필드 정의가 잘못된건지 확인좀 부탁드려요
|

댓글 7개

응? 이거 나만 그런건가.. 설치하고 보니까 member테이블도 기본값누락된 테이블 설정때문에 관리자 아이디가 안들어가고 설치됬네요

mb_signature = '',
mb_memo = '',
mb_lost_certify = '',
mb_profile = '',
text 필드에는 default value 를 선언하지 않도록 되어 있으므로 insert 시에 기본값을 넣지 않아도 설치시 오류가 발생하지 않고 있습니다.
사용하시는 mysql 버전을 알려주십시오.
윈도우 xampp 에서도 설치해 보았으나 별다른 오류는 보이지 않습니다.
음.. 버젼이 낮아서 그런가요? 5.0.7인거 같은데..
리눅스용 mysql 5.1.3 에서는 별다른 오류가 보이지 않습니다.
윈도우용은 버전이 좀 높네요. 5.5.27
음.. autoset으로 깔았다가 ampsetup로 바꿨더니 되네요.. mysql버젼때문에 그런거 맞나봐요
답변 감사합니다
제가 MYSQL 5.5를 쓰는데요... 버전 문제인듯합니다.

5.0이상??에서는 TEXT타입 컬럽에는 DEFAULT를 ''이나 NULL을 쓸수 없고 반드시 DEFAULT는 있어야 하는것같네요.

my.ini에서 sql-mode를

sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

에서

sql_mode="MYSQL40"

로 바꿔주면 됩니다.

http://stackoverflow.com/questions/3466872/why-cant-a-text-column-have-a-default-value-in-mysql
댓글을 작성하시려면 로그인이 필요합니다.

버그신고

4,191건

  문의게시판을 이용해 주세요 :) https://sir.kr/co_qa  

+
분류 제목 글쓴이 날짜
13-06-23
13-06-23
13-06-22
13-06-21
13-06-21
13-06-17
13-06-14
13-06-14
13-06-14
13-06-11
13-06-10
13-06-08
13-06-08
13-06-07
13-06-07
13-06-04
13-06-04
13-06-04
13-06-04
13-06-03