관리자 계정으로 게시판에 파일 업로드시..
용량큰 파일을 업로드하면 제목과 내용을 입력하라는 메세지가 뜹니다.
업로드 파일용량 체크하는 부분이 잘못되서 그런게 아닌가 싶은데요.
아 그리고 파일을 여러개 올릴때도 합친 용량이 서버 설정용량을 넘으면 마찬가지로 제목과 내용을 입력하라는 메
세지가 뜨는것같습니다. 감사합니다. 수고하세요. ^^
업로드 파일용량 체크하는 부분이 잘못되서 그런게 아닌가 싶은데요.
아 그리고 파일을 여러개 올릴때도 합친 용량이 서버 설정용량을 넘으면 마찬가지로 제목과 내용을 입력하라는 메
세지가 뜨는것같습니다. 감사합니다. 수고하세요. ^^
|
댓글을 작성하시려면 로그인이 필요합니다.
댓글 4개
$upload_max_filesize = ini_get('upload_max_filesize');
if (empty($_POST)) {
alert("파일 또는 글내용의 크기가 서버에서 설정한 값을 넘어 오류가 발생하였습니다.\\npost_max_size=".ini_get('post_max_size')." , upload_max_filesize=".$upload_max_filesize."\\n게시판관리자 또는 서버관리자에게 문의 바랍니다.");
}
이 부분을 비교를 맨 처음 하도록 위로 올리니 메세지는 제대로 나오는듯한데요.
위의 비교문도 위로 올려도 되는건지 모르겠습니다.
서버의 post 최대 용량을 변경하시면 해결이 가능합니다.
파일용량 초과하면서 post 값을 잃어버리는 것 까지는 알았지만
(post값을 잃어버려서 제목, 내용이 사라지고, 그래서 제목과 내용 입력하라는 에러메시지 출력)
파일용량 체크 등 코드 수정으로 해결하려다 다 실패했지요ㅎㅎ
혹시나 싶어서
upload_max_size보다 post_max_size 를 더 크게 설정했더니 넘 간단하고 시원하게 해결이 되었어요ㅎㅎ
예전 글이지만.. 댓글 달아둡니다ㅠㅠㅎㅎ