솔그루

이모지 입력시 저장 오류 수정

· 2024-06-27 (목) 11:58:20 · 3855 · 1

최근에는 utf8mb4 를 기본 캐릭터셋으로 사용하여 문제가 발생하지 않지만,

기존에 이미 utf8(utf8mb3) 캐릭터셋으로 설정된 게시판이나, db 에서는 이모지가 입력안되는 오류가 있습니다.

 

그냥 이모지 문자만 입력안되는게 아니라, 내용 전체가 제대로 입력 안되는 오류가 발생합니다.

 

이런 상황을 해결하기 위해서 아래와 같이 코드를 추가합니다.

 

[code]

// /bbs/write_update.php 상단에 추가합니다.
//utf8 에서 허용하지 않는 이모지 문자를 대체
$emoji_pattern = '/[\x{10000}-\x{10FFFF}]/u';
$wr_content = preg_replace($emoji_pattern, '◻', $wr_content);

[/code]

 

 

|

댓글 1개

감사 합니다.

댓글을 작성하시려면 로그인이 필요합니다.

그누보드5 팁자료실

2,788건
+
제목 글쓴이 날짜 조회
24-07-23 조회 3,579
24-07-18 조회 4,273
24-07-15 조회 4,031
24-07-14 조회 3,322
24-07-12 조회 4,897
24-07-11 조회 3,727
24-07-11 조회 3,606
24-06-27 조회 4,184
24-06-27 조회 3,856
24-06-26 조회 3,629
24-06-20 조회 3,936
24-06-14 조회 3,399
24-06-12 조회 3,851
24-06-11 조회 4,017
24-06-10 조회 3,695
24-06-06 조회 3,757
24-06-04 조회 4,399
24-06-03 조회 4,091
24-05-30 조회 3,646
24-05-27 조회 3,582
24-05-24 조회 7,691
24-05-21 조회 3,650
24-05-20 조회 3,579
24-05-17 조회 3,421
24-05-16 조회 4,087
24-05-14 조회 4,048
24-05-13 조회 3,614
24-05-10 조회 61만
24-05-08 조회 3,704
24-05-07 조회 4,721