리자

libphp4.so: cannot restore segment prot after reloc: Permission denied 

· 2007-10-17 (수) 16:36:29 · 4371

[root@localhost libexec]# /usr/local/apache/bin/apachectl configtest
Syntax error on line 224 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: cannot restore segment prot after reloc: Permission denied

이런 황당한 에러는... 아래와 같이 하면 해결됨.

[root@localhost libexec]# restorecon -R -v /usr/local/apache/libexec

또는

[root@localhost libexec]# chcon -t texrel_shlib_t /usr/local/apache/modules/libphp4.so

[이 게시물은 관리자님에 의해 2011-10-31 17:32:05 Linux에서 이동 됨]
|
댓글을 작성하시려면 로그인이 필요합니다.

개발자팁

5,403건

개발과 관련된 유용한 정보를 공유하세요. 질문은 QA에서 해주시기 바랍니다.

+
분류 제목 글쓴이 날짜 조회
기타 07-11-16 조회 5,564
Flash 07-11-13 조회 4,578
정규표현식 07-11-10 조회 6,592
JavaScript 07-11-08 조회 5,654
기타 07-11-07 조회 4,387
기타 07-11-06 조회 3,767
JavaScript 07-11-06 조회 4,555
기타 07-11-05 조회 5,178
MySQL 07-11-02 조회 4,721
기타 07-11-01 조회 5,683
기타 07-10-30 조회 3,833
JavaScript 07-10-26 조회 5,386
기타 07-10-25 조회 3,737
JavaScript 07-10-24 조회 4,245
MySQL 07-10-24 조회 4,498
MySQL 07-10-24 조회 3,677
MySQL 07-10-24 조회 3,667
기타 07-10-22 조회 4,179
JavaScript 07-10-22 조회 3,580
기타 07-10-22 조회 4,223
PHP 07-10-22 조회 3,822
JavaScript 07-10-19 조회 4,738
기타 07-10-19 조회 3,152
Flash 07-10-19 조회 5,135
기타 07-10-17 조회 4,372
Flash 07-10-17 조회 6,969
기타 07-10-16 조회 5,294
기타 07-10-15 조회 6,582
MySQL 07-10-13 조회 6,757
JavaScript 07-10-09 조회 4,805