건

윈도우2003 + Apache 를 위한 SSL 보안서버 구축 팁

· 2008-04-17 (목) 10:05:39 · 4480

관리하는 쇼핑몰에서 보안서버구축 공문을 받아 작업할때 나타난 작은 에러의 해결법입니다.
서버는 Window2003+APM 입니다.
먼저 Apache에 mod_ssl 을 추가한 후 ssl.conf 파일을 호출하도록 적용하였습니다.
다음 윈도우용 Openssl 에서 [Win32 OpenSSL v0.9.8e Light] 를 설치하였습니다.
보안서버는 가장 저렴한 업체인 comodossl.co.kr 에서 인증서를 구입하였습니다.
다음 comodossl 에 나와있는 구축설명서 대로 key 파일과 csr 을 생성, 주문하여 인증서를 받았습니다.

하지만 Apache 에 SSL 을 적용후 재시작하는 과정에 에러가 나와 error.log 파일 확인결과 아래와 같은 에러나타났습니다.

[error] Init: SSLPassPhraseDialog builtin is not supported on Win32 (...

인증서 주문시 서버 선택이 있는데 iis 로 주문한것(클라이언트가 주문)이 잘못되었나 싶어 apache 로 바꾸어 재요청여 인증서를 다시 받았으나 위와 같은 오류가 계속 납니다.

원인을 해결하기 위해 구글링 한 결과 다음과 같은 내용을 찾을 수 있었습니다.

Error: Init: SSLPassPhraseDialog builtin is not supported on Win32
Unfortunately Apache on Windows does not support encrypted private keys. To resolve this you will need to remove the private key password.

It is possible to create an unencrypted copy of the key using this command: openssl rsa -in file1.key -out file2.key

file2.key will contain your unencrypted key.

If you now point your server at this key file, it will not prompt you for a pass phrase.

즉, 키를 만들때 [암호화를 하면 Window 용 Apache 에서는 동작할 수 없다]는 내용입니다.
그렇게 하여 comodossl 의 개인키 생성시 사용한 옵션 중 -des3 라는 구문을 사용하지 않고 만들었습니다.
"openssl>genrsa -des3 -out domain.key 1024 "를
"openssl>genrsa -out domain.key 1024 " 로 key 로 생성
그리고 comodossl 에 찾은 내용을 메일로 보내고 다시 인증서를 받아 설치하고 Apache를 재시작 하니 올바르게 시작되었습니다.
다만 암호화를 하지 않은 키파일이기 때문에 사용시에 암호를 확인하지 않으니 복사에  신중을 기해야합니다.
사실.. 단순히 보안인증서버를 위한것이기 때문에 누군가 받아간다고 해도 걱정할 필요는 전혀 없습니다. ㅡ_ㅡ;;

다른 분들은 삽질하지 마시길.. ㅠㅡㅠ



출처 : Battlej's Working room
[이 게시물은 관리자님에 의해 2011-10-31 17:30:25 Apache에서 이동 됨]
|
댓글을 작성하시려면 로그인이 필요합니다.

프로그램

8,188건
+
제목 글쓴이 날짜 조회
08-04-17 조회 4,485
08-04-17 조회 5,560
08-04-17 조회 3,700
08-04-17 조회 8,679
08-04-17 조회 5,156
08-04-17 조회 5,356
08-04-17 조회 3,553
08-04-17 조회 4,326
08-04-17 조회 4,904
08-04-17 조회 5,256
08-04-17 조회 4,481
08-04-17 조회 4,466
08-04-17 조회 4,593
08-04-17 조회 3,665
08-04-17 조회 3,244
08-04-17 조회 4,270
08-04-17 조회 4,495
08-04-17 조회 5,904
08-04-17 조회 2,750
08-04-17 조회 3,881
08-04-17 조회 3,934
08-04-17 조회 3,102
08-04-17 조회 3,432
08-04-17 조회 3,068
08-04-17 조회 3,573
08-04-17 조회 4,937
08-04-17 조회 5,085
08-04-17 조회 3,309
08-04-16 조회 2,473
08-04-15 조회 2,610
08-04-14 조회 2,764
08-04-14 조회 2,749
08-04-11 조회 2,525
08-04-11 조회 2,655
08-04-11 조회 2,460
08-04-09 조회 3,050
08-04-08 조회 4,085
08-04-07 조회 3,001
08-04-07 조회 2,563
08-04-06 조회 2,807
08-04-06 조회 3,521
08-04-05 조회 3,103
08-04-05 조회 2,362
08-04-04 조회 7,162
08-04-04 조회 4,569
08-04-04 조회 4,452
08-04-04 조회 3,799
08-04-04 조회 4,017
08-04-04 조회 4,032
08-04-04 조회 4,487
08-04-04 조회 3,658
08-04-04 조회 3,801
08-04-04 조회 3,918
08-04-04 조회 3,822
08-04-04 조회 3,981
08-04-04 조회 4,535
08-04-04 조회 3,970
08-04-04 조회 2,815
08-04-04 조회 4,175
08-04-04 조회 2,862
08-04-04 조회 2,748
08-04-04 조회 3,284
08-04-04 조회 2,807
08-04-04 조회 2,684
08-04-04 조회 2,645
08-04-04 조회 2,877
08-04-04 조회 3,358
08-04-04 조회 2,701
08-04-04 조회 2,687
08-04-04 조회 2,531
08-04-04 조회 2,722
08-04-04 조회 2,554
08-04-04 조회 2,594
08-04-04 조회 2,884
08-04-04 조회 2,752
08-04-04 조회 2,622
08-04-04 조회 2,572
08-04-04 조회 2,639
08-04-04 조회 2,476
08-04-04 조회 2,501
08-04-04 조회 2,564
08-04-04 조회 2,619
08-04-04 조회 2,603
08-04-04 조회 2,710
08-04-04 조회 2,642
08-04-04 조회 2,987
08-04-04 조회 4,119
08-04-03 조회 4,542
08-04-03 조회 2,665
08-04-03 조회 2,792
08-04-03 조회 2,587
08-04-03 조회 3,316
08-04-03 조회 4,270
08-04-03 조회 2,540
08-04-03 조회 2,455
08-04-03 조회 2,645
08-04-03 조회 2,601
08-04-03 조회 2,792
08-04-03 조회 2,770
08-04-03 조회 2,645