녹

아파치님 질문

· 2018-03-27 (화) 23:32:31 · 2159 · 11

루트로 이동해

[root@localhost ~]# ./restart.sh
Job for nginx.service failed because the control process exited with error code. See "systemctl status nginx.service" and "journalctl -xe" for details.
 

없던 메세지가 뜨네요

 

왜그런걸까요?

|

댓글 11개

답은 모르겠지만, 내용을 보면, systemctl status nginx.service 나 journalctl -xe 를 실행시켜서 나온 출력까지 올려놔야 보고 알 수 있지 않을까요?
2018-03-28 (수) 06:52:19
@마젠토 답변 감사합니다
계정 추가후에 conf 파일 수정하면서 문제가 있는 모양 입니다.
해당 conf 를 예제를 보고 수정해 주신후 다시 실행 해 보세요.
그리고 log 파일을 보면 문제점 파악이 되실겁니다.
서버 살펴보니 letsencrypt ssl 설정중에 계정 누락된 부분이 있네요.
/etc/letsencrypt/archive 폴더에 누락된 계정을 ssl 설정후에 ./restart.sh 를 진행해 주시면 되겠네요.

먼저 letsencrypt ssl 설정후에 conf 파일을 수정해 주셔야 문제가 발생하지 않습니다.
2018-03-28 (수) 06:51:38
@亞波治 아 원인을 알았습니다 ㅎㅎㅎ 5.3으로 계정만들어놓구 7.0으로 불러서 ;;
@200점아빠 php버전은 상관없습니다.
conf 파일에서 http와 https 의 php버전을 동일하게 바꾸고 ./restart.sh 를 진행하면
바뀐 php버전으로 사이트가 운영 됩니다.
2018-03-28 (수) 07:07:21
@亞波治 그렇네여
2018-03-28 (수) 07:18:03
@亞波治 똑같은 파일을 해서 올렸는데 homepage01.conf 이것만 올라가면 그러네요 내용 동일한데
@200점아빠 아까 살펴보니 homepage01 계정의 ssl 추가를 안하신듯 합니다.
예제 파일을 보시고 homepage01 계정의 ssl 추가후에 리스타트 하시면 이상없을겁니다.

ssl 이 적용되었는지 확인 하시려면 /etc/letsencrypt/archive 에 해당 계정의 도메인이 있는지 확인 하시면 됩니다. 없다면 ssl 을 추가 해 주시면 됩니다.
2018-03-28 (수) 08:13:04
@亞波治 아 한가지 빼먹은게 ㅠㅠ 있었구나
2018-03-28 (수) 08:19:40
감사합니다 이제 스스로 연구 하고 배우도록하겠습니다
댓글을 작성하시려면 로그인이 필요합니다.

서버관리자

658건

서버관리자 모임 게시판 입니다.

+
제목 글쓴이 날짜 조회
18-09-21 조회 4,507
18-09-15 조회 2,676
18-08-27 조회 2,494
18-08-12 조회 2,466
18-08-03 조회 2,556
18-07-03 조회 1,747
18-06-21 조회 1,963
18-06-08 조회 2,286
18-06-07 조회 2,202
18-05-30 조회 2,638
18-05-15 조회 2,486
18-05-08 조회 3,909
18-04-08 조회 3,292
18-04-07 조회 4,372
18-04-05 조회 2,103
18-04-03 조회 2,396
18-03-31 조회 2,541
18-03-29 조회 2,115
18-03-28 조회 1,958
18-03-27 조회 2,160
18-03-26 조회 1.1만
18-03-20 조회 2,197
18-03-17 조회 2,391
18-03-17 조회 2,159
18-03-14 조회 2,564
18-03-05 조회 2,031
18-03-05 조회 2,240
18-03-05 조회 2,420
18-03-04 조회 2,678
18-03-03 조회 1,977