그누보드.. Flash로 된 이미지 업로드 기능 오류 시

그누보드.. Flash로 된 이미지 업로드 기능 오류 시

QA

그누보드.. Flash로 된 이미지 업로드 기능 오류 시

본문

안녕하세요 형님들.

전 개발자가 아닙니다.

소스 한줄을 보면 '아.. 이런건가..?' 추측할 순 있지만.. 개발자가 아녜요.

 

그런데. 

예전에 만들었던 회사 홈페이지의 게시판에 이미지를 올리려고 하면 오류가 납니다.

editor 영역으로 이미지를 드래그 앤 드랍하면 '크롬 브라우저의 새탭으로' 열려요.

editor 메뉴 중 이미지 업로드 버튼을 누르면 이미지를 찾는 버튼 부분에

3543545853_1656909472.8977.png

위와 같이 그.. Flash 미지원 이미지?? 로 표시가 되요.

 

음...

형님들 뭘 어떻게 해야할지 모르겠습니다.

게시판 자체를 업그레이드 해야 하는건지, 업그레이드가 가능은 한건지..

아니면 일부 소스를 수정하면 되는건지.

(참고로 개발자가 없어요. 잠수 탔어요. 연락이 안돼요. 사장님이 저보고 고치래요)

 

저희 게시판 관리자 화면은 이렇게 생겼어요

3543545853_1656909800.2634.png

 

형님들 질문 드려요.

 

1. 게시판 업그레이드를 하게되면, 현재 홈페이지 게시판 디자인이 틀어지거나 하지는 않을까요?

 

2. 저 상태에서 게시판 버전? 업그레이드가 가능 한가요?

 

3. 이미지 업로드 오류를 잡을 수 있는 가장 효율적인 방법은 무엇일까요?

 

4. 참고로 그.. 제가 잘 몰라서 일단 적어보면 카페24호스팅 쓰고 있고, PHP5.5 MySQL.. 이렇게 되어 있어요

 

후.. 질문이 너무 막막하면

참고할 수 있는 링크만 주셔도 황송하게 받겠습니다.

 

형님들. 도와주십쇼. 

이 질문에 댓글 쓰기 :

답변 5

플래시 지원이 종료되었기에 예전 버전 cheditor5는 업데이트가 필수로 필요합니다
 

cheditor5 업데이트하세요
그누보드5 최근버전은 모두 업데이트되어있으니 플러그인에서 cheditor5만 받아서 업데이트하셔도될겁니다

아.. 플러그인에서 cheditor5만 받아서 업데이트.. 네 찾아보겠습니다.
감사합니다.
부장님이 아직도 안되냐며 자꾸 뭐라 하십니다. 참 답답하네요. ㅠㅠ

근데 관리자화면을 보니 g4같은데... 살짝 주의는 하셔야될것같아요
백업은 필수로하시고 g4는 제가 본적이없어서 모르겠는데
g5 에디터와 호환이 될지 모르겠네요

아 내부 변수랑 상수들 g4에 맞게끔 수정도 해야할것같네요
개발자가 아니라면 조금 힘들수도있겠네요

제일 좋은건 그누보드에 탑재된 다른 에디터인 스마트에디터2가 있으면 그걸로 바꿔서 사용하시는것도 방법일것같네요

아 폴리시아 형님 송구합니다.
https://sir.kr/g5_pds/5708?sfl=wr_subject%7C%7Cwr_content&stx=cheditor5
여기서 파일을 받는 것이 맞는지 여쭤도 되겠습니까?

파일이 두개인데 둘 다 받으면 되는건지 알려주실 수 있을까요?

받으실꺼면 https://sir.kr/g5_pds/6580 최신버전에 위쪽파일을받으면됩니다 (아래는 패치내용만 포함된 패치파일입니다)

최신버전에서 /plugin/editor 부분에 cheditor5가 있는데 이걸 가져다 쓰면됩니다

다만 앞서 말했던 우려되는부분들이 있으니 현재 그누보드 버전 체크먼저 해보시길 바랍니다

2021년 1월 12일 부로 플래시 플레이어 미지원으로 사용이 안됩니다.

본인 컴퓨터에서 플래시 확인을 위해서는 아래 링크를 참고하세요.

https://algo79.tistory.com/entry/flash-player-%EB%AF%B8%EC%A7%80%EC%9B%90%EC%97%90-%EB%94%B0%EB%A5%B8-%EB%8C%80%EC%9D%91%EB%B0%A9%EB%B2%95

아 감사합니다.

그게 지금 보니 디렉터리 구조가

3543545853_1656913531.6826.png

이렇습니다.

cheditor5 라고는 되어있는데.. 확인이 서지 않아서 망설이는 중입니다.

일단 업데이트 전 백업을 받으라고 하셔서 백업 받는 방법을 찾고 있습니다.

큰 도움이 되어 주셔서 감사드립니다.

 

이거 보니까.. plugin 폴더는 비어있고,
data란 폴더에 들어가보니
- cheditor4
-file
-log
-memver
-naver
-session
-smartdetor2
이렇게 디릭토리가 있습니다.
버전이 뭔지 모르겠습니다.
버전 확인은 어디서 가능하겠습니까?

이걸보니 g4가 맞긴한가보네요
구조가 g4 기본구조인지는 잘모르겠습니다
www/cheditor5가 지금쓰고 있는 에디터인지 확인하셔야할것같고...
흠... 이렇게만해서는 솔직히 모르겠습니다
다 추측만 될뿐이지 이게 맞다라고 하기엔 힘드네요

기본 g4에 커스텀이 들어간것같긴한데 에디터를 스마트에디터로 관리자에서 교체가 가능하면 교체하시고 아니면.. 해당 구조에 맞게끔 최신버전의 cheditor5를 수정해서 적용하는수밖에 없을것같네요

와...진짜 옛날 관리자페이지네요..ㅎㅎ;

 

윗분들말씀대로 플래시 지원 문제인데 플래시를 지원하는 브라우저에서는 잘나오나요?

익스플로러로 해보셨나요?

 

만약에 다른브라우저로 업로드가 가능하시면 기존꺼 수정하기보다는 다른브라우저로 사용하는게 정답일 수 있을 것 같습니다ㅠ

답변을 작성하시기 전에 로그인 해주세요.
전체 112,674 | RSS
QA 내용 검색

회원로그인

(주)에스아이알소프트 / 대표:홍석명 / (06211) 서울특별시 강남구 역삼동 707-34 한신인터밸리24 서관 1404호 / E-Mail: admin@sir.kr
사업자등록번호: 217-81-36347 / 통신판매업신고번호:2014-서울강남-02098호 / 개인정보보호책임자:김민섭(minsup@sir.kr)
© SIR SOFT