그누보드(영카트) 5.4.12 > 영카트5 다운로드

영카트5 다운로드

그누보드(영카트) 5.4.12 정보

그누보드(영카트) 5.4.12

첨부파일

gnuboard5-5.4.12.zip (11.9M) 357회 다운로드 2021-07-20 10:32:55
gnuboard5-5.4.12.tar.gz (10.2M) 62회 다운로드 2021-07-20 10:32:55
gnuboard5.4.12.patch.zip (16.5K) 95회 다운로드 2021-07-20 10:32:55

본문

# 변경된 사항

버전 5.4.12 수정
https://github.com/gnuboard/gnuboard5/commit/1d89af99b02127aba64124673758067960637b46

PHP 5 하위버전에서 상수 배열이 지원되지 않아 나오던 오류 수정 (한별아빠님,210719)
https://github.com/gnuboard/gnuboard5/commit/81635f77373a2e1343336dda848cf3625a2e5a1b

skin 디렉토리가 없거나 경로가 잘못 된 경우 나오는 오류 수정 PHP Warning:  array_merge(): Argument #2 is not an array (엑스엠엘님,210716)
https://github.com/gnuboard/gnuboard5/commit/e1e20f2dc245ec4ac5039a533a037872b28a5436

댓글 18개

감사합니다.
그런데 5.4.12버전은 webp 파일 지원하지 않고 5.4.11버전만 지원하는건가요?
5.4.10버전에서 5.4.11버전 업데이트 후 5.4.11버전까지 업데이트 하는중인데,
5.4.11버전 config.php 하단에
define('G5_IMAGE_EXTENSIONS', array(1=>'gif', 2=>'jpg', 3=>'png', 18=>'webp'));
가 추가되어 있었는데,
5.4.12버전에는 또 이게 없어서요.
@KKONDAE
define('G5_IMAGE_EXTENSIONS', array(1=>'gif', 2=>'jpg', 3=>'png', 18=>'webp'));
이 코드 삭제해 주십시오.
PHP 5 하위버전에서 상수 배열 기능을 지원하지 않아 다른 코드로 대체 했습니다.

그누보드 5.4.11 이상 부터는 webp 가 지원됩니다.
webp 지원전에 아래 글을 참고해 주세요.
https://sir.kr/g5_pds/5911
스마트 에디터로 올린 큰 이미지 게시물에서
본문에 썸네일이 아닌 원본 파일로 뜨면서
새창으로 뜨지 않는 오류가 발생합니다.
@리자    jpg 파일입니다.
기존 jpg 게시물, 신규로 올리는 jpg 모두 그럽니다.
파일첨부로 올린 jpg 파일은 이상없는데
스마트에디터로 올린 jpg 만 그럽니다.
@아가싱즈 jpg 관련해서는 코드를 건드린 것이 없는데 이상하네요.
저희가 확인 할 수 있는 URL 과 관리자 정보, FTP 정보를 *** 개인정보보호를 위한 이메일주소 노출방지 *** 로 알려주시면 확인 후 답변 드리겠습니다.
앞으로는 PHP 7 이상을 써야 안전(안정적인)한 그누보드를 정상적으로 사용할 수 있나요?
현재 5.2.x 와 5.3.x 를 쓰고 있는데 ㅠㅠ
현재 그누보드에 궁합이 잘 맞는 APM 버전을 알려주실 수 있을까요?
리눅스 이름과 버전도 알려주시면 감사하겠습니다.
여기서 이렇게 물어봐도 되는지...
@큐니 지금도 PHP5.x 버전을 사용하는 곳이 있어 당장 PHP 7.x 로 전환은 무리라고 생각합니다.
그래도 차근차근 PHP 7.x 전환하는 것을 고려하셔야 합니다.
이왕이면 PHP 8.x 로 바꾸시는게 더 낫겠네요.
전체 236 |RSS

회원로그인

(주)에스아이알소프트 / 대표:홍석명 / (06211) 서울특별시 강남구 역삼동 707-34 한신인터밸리24 서관 1404호 / E-Mail: admin@sir.kr
사업자등록번호: 217-81-36347 / 통신판매업신고번호:2014-서울강남-02098호 / 개인정보보호책임자:김민섭(minsup@sir.kr)
© SIR SOFT